firebase-coreを16.0.6から16.0.7にアップデートする際の設定

‘com.google.firebase:firebase-core:16.0.6’
から
‘com.google.firebase:firebase-core:16.0.7’
に変更しようとするとエラーが出ます。


org.gradle.api.resources.ResourceException: Could not get resource 'https://dl.google.com/dl/android/maven2/com/google/firebase/firebase-measurement-connector-impl/17.0.5/firebase-measurement-connector-impl-17.0.5-javadoc.jar'.
・・・

対応としては下記gradle-wrapper.propertoesを下記に変更することで回避できます。

distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.1-all.zip

distributionUrl=https\://services.gradle.org/distributions/gradle-5.2.1-bin.zip

また、analyticsが別ライブラリとして分割されましたが、16.0.7でまたcoreに入ったようですね。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

Bitnami